Some meetings are showing an error when attempted to be rescheduled from the Meetings Tab
Incident Report for Calendly
Resolved
Testing and reports have indicated this is now resolved.
Posted Nov 12, 2024 - 11:25 EST
Monitoring
A fix has been implemented and we are now actively monitoring.
Posted Nov 12, 2024 - 11:10 EST
Identified
We have identified where the issue is stemming from and are actively working on a fix.
Posted Nov 12, 2024 - 10:16 EST
Investigating
Some users are reporting an inability to reschedule certain meetings via the Meetings Tab. We are actively investigating this issue.

Meetings can still be rescheduled by using the link in the original confirmation email near the bottom. Alternatively, you can cancel the event and use the “Schedule Invitee Again” option to set up a new time.
Posted Nov 12, 2024 - 10:14 EST